Equipos Windows se me pelean por las IP’s en mi Wlan

wlanÚltimamente he estado pensando sobre mi red local pues he estado teniendo problemas. Específicamente, los equipos con Windows 7 tienen problemas para conectarse a la red, mostrando el mensaje:

“Señal excelente. La configuración de red guardada en este equipo no coincide con los requisitos de la red”

Un arreglo a esto es borrar la conexión de red y volver a crearla, pero el problema vuelve a salir. No sirve reiniciar el equipo ni el módulo wifi.

He planteado este problema a la gente de Desde Linux, pero nada por ahora.

He conseguido clarificar un poco el problema, pero no solucionarlo, gracias a algunas cosas que aprendí en las lejanas y odiadas clases de filosofía, resulta que al final sí sirven de algo.

  1. Mi red usa DHCP.
  2. El router asigna IP’s del rango de 100 a 199 (establecido en la configuración).
  3. Cuando un cliente se conecta asigna la primera IP disponible/libre/sin cliente conectado del rango.
  4. Un cliente mantiene la misma IP mientras que permanece conectado.
  5. El “Time to live” es de 2 horas, luego si un cliente se desconecta, se le guarda la IP durante 2 horas.
  6. Si se conecta otro cliente en esas 2 horas y la primera IP disponible es la que tenía el otro cliente, se le asigna esa IP.
  7. El cliente de Windows 7 (en linux no pasa y no tengo otros windows), aunque tenga en su configuración “IP asignada por DHCP”, recuerda la IP asignada de antes, pero no se puede conectar porque la IP está ocupada.
  8. Si el router se reinicia, se desconectan todos los clientes.

Ahora, en caso de reiniciar el router, no sé si los dos clientes Windows consiguen conectarse o solo uno de ellos (sólo hay dos clientes Windows en mi red y uno de ellos es un vecino, así que no he podido controlar eso muy bien).

El equipo Windows al que le aparece el mensaje “Señal excelente. La configuración de red guardada en este equipo no coincide con los requisitos de la red” consigue conectarse al cabo de un tiempo. No me he fijado si son 2 horas.

Yo suponía siempre que si un equipo se desconecta de la red y vuelve a conectarse, pide una nueva IP al router en caso de que no tenga establecida una IP fija. Puede que estuviera equivocado, al menos lo que respecta a Windows 7. Puede que Windows pida también el “Time to live” y que durante ese tiempo (de desconexión) no vuelva a pedir una IP nueva.

Como veis, no es una solución, pero al menos sí es una teoría. Espero que esto le sirva como punto de partida a alguien a quién le haya pasado lo mismo que a mí.

PS: Para ahorrarme problemas, le he asignado a todo el mundo IP’s estáticas.

Anuncios

2 pensamientos en “Equipos Windows se me pelean por las IP’s en mi Wlan

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s