The Centos Ruby Dilemma

Estas son algunas divagaciones filosóficas que he tenido hace poco sobre ruby:

  • Si quiero que los programas que no vengan en el sistema, ni en ninguno de sus repositorios originales, sean fáciles de actualizar, tengo que crear un repositorio.
  • Si quiero tener ruby más nuevo desde mi propio repositorio (que sí, pues soy así de guay) tengo que igualar la prioridad de mi repositorio (nfb) al sistema base (que es 1).
  • Si quiero tener estabilidad en el sistema, todos los repositorios que no sean del sistema (valga la redundancia) tienen que tener una prioridad mayor que, ¿adivinan que palabra?, el core.
  • Solución, instalar rvm, que gracias a que tengo algunos repositorios extra, se encuentra en epel 😀

¡La polla! Instalo rvm y me dice (yum info, porque tonto de mí, no se me ocurrió hacerlo antes de instalar) “The RVM persistent recoverable memory library. The RVM library is used by the Coda distributed filesystem”. Vamos, que no es rvm, o por lo menos no el que yo busco.

Joder, acabo de ver en www.ruby-lang.org/es/news/2012/07/05/ruby-1-8-7-p370-liberado-/ que la versión 1.8.7-p370 (a lo que Centos llamaría 1.8.7.370) no se desarrolla mas desde el junio de este año y tendrá actualizaciones de seguridad hasta el junio de 2013. ¿Y sabéis que versión viene con el 6.3? Ruby 1.8.7.352, ¡ZAS EN TODA LA BOCA!

Me imagino que por el junio de 2013 ya tendremos la versión 1.8.7-p370 en Centos.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s